Connexion à votre interface Wifeo
X
Nom d'utilisateur :
Mot de passe :


Mot de passe oublié ?

Pas encore inscrit ? Créez votre site gratuitement !
Connexion
 FERMER LE MENU


Menu du forum :

Accueil du forum

Derniers messages

S'inscrire au forum

Se connecter au forum

Mot de passe oublié

Menu général de Wifeo :

Accueil de Wifeo

Connexion

Créer un site

Nouveautés Wifeo

Blog

Forum

Boite à outils

Documentations

Design vierge à créer > Disparition d'un background

Connectez-vous au forum     Pas inscrit au forum ? Inscrivez-vous !
Nom d'utilisateur : Mot de passe :
Se connecter automatiquement à chaque visite

Disparition d'un background

La question
Posté le 25 Août 2015 à 21:52
on dort chez toi


1982 messages
Inscrit le 10/12/2009
Mon site
Bonjour,

Je suis sur un véritable casse tête !
Afin de rendre l'esthétique de mon site plus jolie avec les pub (728px de large) je suis entrain de refaire mon design, en PX et plus en %

J'aimerai :
Corps 728 px
zone big ( celle de droite ) 300 px
un espace vide entre le corps et la zone big de 20px
des bords droite et gauche de 20 px

soit un total de :

3 x 20 px
1 x 728 px
1 x 300 px

donc 1088 px ( on est bien d'accord ? )

En suite pour la partie mobile j'aimerai avoir un espace vide sur les cotés, j'aimerai que mon site corps et big ne touche pas les cotés de l'écran mobile. Donc j'ai ajouté une colonne de 20px de chaque coté, que je fais disparaitre sur ordinateur.

Mon problème est le suivant :

Sur ma page d'accueil test
http://www.blogphotographe.fr/zzz-acceuil-test.php

Je voie bien le bord gauche ( trait gris qui ferme le coté gauche du site ) par contre le bord droit disparait quand je met un tableau dans la partie big ( celle de 300px )

En gros site je ne met rien dans la zone big, le bord droit s'affiche. Par contre si je met un nouveau tableau dans cette colonne, le bord disparait !

Je ne comprend pas pourquoi ! J'ai fais des test en réduisant les tailles corps, espace vide entre le corps et la zone big, j'ai essayé de supprimer l'image et de la remettre mais rien à faire

Une idée du soucis ?

PS : désolé pour le titre, je ne sais pas comment expliquer le problème.
La zone big c'est la partie à droite qui fait 300 px de large ( normalement big annonce si je supprime les pubs )

Si besoin le code source de mon design
   SCRIPT
<table align="center" border="0" cellpadding="0" cellspacing="0" style="width: 1088px;">
<tbody>
<tr>
<td class="wr_dsplypc" style="text-align: left; vertical-align: top; width: 20px;"> </td>
<td style="width: 1088px; background-color: rgb(204, 204, 204);"> </td>
<td class="wr_dsplypc" style="width: 20px;"> </td>
</tr>
<tr>
<td class="wr_dsplypc" style="text-align: left; vertical-align: top;"> </td>
<td style="text-align: left; vertical-align: top;">
<table align="center" border="0" cellpadding="0" cellspacing="0" height="69" width="1088">
<tbody>
<tr>
<td background="http://blogphotographe.wifeo.com/images/b/bac/back-bord-gauche.png" class="wr_dsplymbl" style="width: 20px; text-align: left; vertical-align: top; background-position: left top;"> </td>
<td style="text-align: left; vertical-align: top; width: 728px; background-color: rgb(255, 255, 255);">{corps}</td>
<td class="wr_dsplymbl" style="width: 20px;"> </td>
<td class="wr_dsplymbl" style="text-align: left; vertical-align: top; width: 300px; background-color: rgb(255, 255, 255);"> </td>
<td background="http://blogphotographe.wifeo.com/images/b/bac/back-bord-droit.png" class="wr_dsplymbl" style="width: 20px; background-position: left top;"> </td>
</tr>
</tbody>
</table>
</td>
<td class="wr_dsplypc" style="text-align: left; vertical-align: top;"> </td>
</tr>
<tr>
<td class="wr_dsplypc"> </td>
<td> </td>
<td class="wr_dsplypc"> </td>
</tr>
</tbody>
</table>

 
Navigateur utilisé : Firefox
 
Dernière modification du message le 25/8/2015 à 21:55:37.

La réponse qui règle le problème
Posté le 26 Août 2015
on dort chez toi


1982 messages
Inscrit le 10/12/2009
Mon site
Je ferme ce post
je dois avoir le site le plus fini possible dans les jours à venir

donc je refait tout à 100% de manière la plus simple possible
 
Navigateur utilisé : Firefox


 
Posté le 26 Août 2015 à 9:32
vincent-support

Bonjour Cédric , j'ai pas regardé longtemps, mais il y a déjà un truc qui me chiffonne au debut de ton code :

<table align="center" border="0" cellpadding="0" cellspacing="0" style="width: 1088px;">
<tbody>
<tr>
<td class="wr_dsplypc" style="text-align: left; vertical-align: top; width: 20px;"> </td>
<td style="width: 1088px; background-color: rgb(204, 204, 204);"> </td>
<td class="wr_dsplypc" style="width: 20px;"> </td>
</tr>

Tu as une table de 1088 px de large qui contient des colonnes de 20 px + 1088 px + 20px

20 + 1088 + 20 = 1088 ? Bizarre non ?

Je pense qu'avec mon indication tu trouveras une solution.

 
Navigateur utilisé : Firefox

Enjoy & share !


 
Posté le 26 Août 2015 à 14:06
on dort chez toi


1982 messages
Inscrit le 10/12/2009
Mon site
    vincent-support A ECRIT :
Bonjour Cédric , j'ai pas regardé longtemps, mais il y a déjà un truc qui me chiffonne au debut de ton code :

<table align="center" border="0" cellpadding="0" cellspacing="0" style="width: 1088px;">
<tbody>
<tr>
<td class="wr_dsplypc" style="text-align: left; vertical-align: top; width: 20px;"> </td>
<td style="width: 1088px; background-color: rgb(204, 204, 204);"> </td>
<td class="wr_dsplypc" style="width: 20px;"> </td>
</tr>

Tu as une table de 1088 px de large qui contient des colonnes de 20 px + 1088 px + 20px

20 + 1088 + 20 = 1088 ? Bizarre non ?

Je pense qu'avec mon indication tu trouveras une solution.


Salut Vincent,

En effet, j'ai 3 colonnes :

20 + 1088 + 20

sauf que les 2 qui font 20px je les est mis en disparition ordinateur. ( je les veux visible uniquement sur mobile )
mais j'ai malgré tout redimensionné mon tableau général à 1128 px mais le problème persiste.

En gros j'ai 3 colonnes 20 + 1088 + 20 ( les 20 sont en disparition ordi )
j'ai en suite refais un autre tableau uniquement dans la colonne 1088

 
Navigateur utilisé : Firefox

 
Posté le 26 Août 2015 à 14:10
vincent-support

ah ok autant pour moi, faudrait que quelqu'un se penche de plus près sur ton code...
 
Navigateur utilisé : Firefox

Enjoy & share !


 
Posté le 26 Août 2015 à 14:12
on dort chez toi


1982 messages
Inscrit le 10/12/2009
Mon site
    vincent-support A ECRIT :
ah ok autant pour moi, faudrait que quelqu'un se penche de plus près sur ton code...


Je viens de faire un test sans les 20

mais toujours le même soucis pourtant le code est plus propre je pense

   SCRIPT
<table align="center" border="0" cellpadding="0" cellspacing="0" style="width: 1088px;">
<tbody>
<tr>
<td style="width: 1088px; background-color: rgb(204, 204, 204);"> </td>
</tr>
<tr>
<td style="text-align: left; vertical-align: top;">
<table align="left" border="0" cellpadding="0" cellspacing="0" style="width: 1088px;">
<tbody>
<tr>
<td background="http://blogphotographe.wifeo.com/images/b/bac/back-bord-gauche.png" style="background-position: left top; width: 20px;"> </td>
<td style="text-align: left; vertical-align: top; width: 728px;">{corps}</td>
<td style="width: 20px;"> </td>
<td style="text-align: left; vertical-align: top; width: 300px;"><img alt="" src="http://blogphotographe.wifeo.com/images/b/bac/back-menu-big.png" style="width: 300px; height: 59px;" /></td>
<td background="http://blogphotographe.wifeo.com/images/b/bac/back-bord-droit.png" style="background-position: left top; width: 20px;"> </td>
</tr>
</tbody>
</table>
</td>
</tr>
<tr>
<td> </td>
</tr>
</tbody>
</table>

 
Navigateur utilisé : Firefox

 
Posté le 26 Août 2015 à 14:17
vincent-support

Ca a l'air bon du coup maintenant je vois bien ta colonne à droite bien placée non ?
 
Navigateur utilisé : Firefox

Enjoy & share !


 
Posté le 26 Août 2015 à 14:33
on dort chez toi


1982 messages
Inscrit le 10/12/2009
Mon site
    vincent-support A ECRIT :
Ca a l'air bon du coup maintenant je vois bien ta colonne à droite bien placée non ?


Bin le soucis est que lorsque je place quelque chose dans la colonne qui fait 300px comme cette image


mon coté droit disparait


Et quand je supprime ce qu'il y a dans la colonne de 300 px mon coté droit revient

 
Navigateur utilisé : Firefox
 
Posté le 26 Août 2015 à 18:26
Je ferme ce post
je dois avoir le site le plus fini possible dans les jours à venir

donc je refait tout à 100% de manière la plus simple possible

 
Navigateur utilisé : Firefox

 
Poster une nouvelle réponse
Connectez-vous au forum pour pouvoir répondre     Pas inscrit au forum ? Inscrivez-vous !
Nom d'utilisateur : Mot de passe :
Se connecter automatiquement à chaque visite
Nous soutenons : Secours Populaire . Enfants du desert . Medecins Sans Frontieres
Copyright © Wifeo.com - Tous droits réservés BOURDET SARL R.C.S.503777286 VERSAILLES